Forums: Adempiereの使い方 (Thread #29543)

インストールについて (2011-06-13 12:14 by tkhiro0712 #57983)

高田です。

ADempiereのインストールは一般の方にはハードルが高い、という意見が別のスレッドで出ています。

一般の方というのはコンピュータに詳しくない人のことだと思いますが、コンピュータに詳しい人でも簡単な方が良いですよね。

詳しい人も詳しくない人も、一緒に議論できるようにスレッドを立てました。
皆さんの参加、よろしくお願いします。

Répondre à 57983×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

RE: インストールについて (2011-06-18 16:14 by tomand #58121)

安藤です。

yatsuzuka様 有難う御座います。

メッセージ [#58067] へのフォロー

> Fedoraですか。安藤さんやりますね!
> Linuxユーザにとっては、こういう情報、とても重要なので、
私は、いつも "日経 Linux" 買って来て、付録の DVDrom から install してましたので、Fedora は普通だと思っていました。
Fedoraは先進的と言う事ですか。?
現在ですと、Ubuntuも多い様に思います。
前回の勉強会でCentOSはどうですかと、聞かれました。以前、CentOSもinstallした事もありましたが、Fedoraの三つぐらい前のversionだったので、古くてつまらないとお答えしました。しかし、server の実運用となると、枯れて安定性がある方が良いんですね。
Windows は、どうかとも聞かれました。Windows では、パソコン止まりでつまらない。Linuxなら、Supercomputer まで行きますとお答えしました。埼玉県和光市に理化学研究所は在りますが、公開日でしたら、実物も見られ、説明もしてくれ、質問も出来ます。Supercomputer に Apache は入っていますかと聞いたら、Apache に限らず、Linux soft なら殆ど入っているとの事でした。税金で運営されている以上、その必要性を国民に理解してもらわないといけませんね。
install 出来ないと、全ての事を疑ってしまいます。fc13には、openJDKが入っています。Adempiereのinternet の記事の多くは、sunJDKを使っています。高田さんにお聞きした所、CentOSとopenJDKでも、動かしているとの事でした。


> Java系Webシステムは、Webサーバ、APサーバ、DBサーバの3層アーキになっているので、
私も、paradox user だったもので、10年位前に、Borland で 三階層architecture の話 聴きました。
Enterprise 規模の話だったと思いますが、ademがそれに該当するとは全く思っていませんでした。
Ademの世界って、生産管理にしても、商業高校2年生 工業簿記 2級簿記 製造原価報告書 迄のお話の様に思いましたが。違ってますか。?


> 近いうちにインストールマニュアルに、Linuxの方のことも追記していきたいと思っています。
もし、私でも、ご協力出来たら、幸いと思っています。

> そこのドライバのセットアップ周りが、Linuxでのインストールの一つの壁で、
fc12の時、ooobase とposgre をodbc接続しようと、odbcDriver 探して苦労しました。
fc13 場合も探し始めると、odbcDriver が openOffice 内に用意されている事が判りました。
fc13では、fc13package内の openOffice, posgre8.4.4, と、このopenOffice内のodbcDriver を使い、繋がりました。


> 私も以前Javaアプリを作っていた頃、RHELではうまくいくのですが、
> Fedoraに移植すると文字化け(豆腐)なんてことがありました。"
> FedoraのFontファイル管理が少しくせがあるんですよね。
> 微妙にRedhatと違っていて、すぐに豆腐状態になってしまいます。"
fc13package内の IPAex明朝 IPAexゴシックを install し、fallback directory に link を張りました。綺麗な文字が表示されます。また、system 全体でも、firefox でも、この font 使う様にしました。


> 先日、カンさんも少し話されていましたが、利用状況によってはJavaのヒープメモリを増やすという処置が
> 必要になってくると思います。Javaはデフォルト512Mしかメモリ領域を確保しないので。
java -Xmx2048m -Xms2048m -Xmn768m -Xss128k -XX:NewRatio=4 これから、勉強してみます。


> 会計周りもふくめて、以後の勉強会のときにでも、色々とお話をきかせてください。
こちらこそ、宜しくお願い致します。
Répondre à #57983

Répondre à 58121×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

RE: インストールについて (2011-06-18 18:51 by syatsuzuka #58126)

> Fedoraは先進的と言う事ですか。?
> 前回の勉強会でCentOSはどうですかと、聞かれました。以前、CentOSもinstallした事もありましたが、Fedoraの三つぐらい前のversionだったので、古くてつまらないとお答えしました。しかし、server の実運用となると、枯れて安定性がある方が良いんですね。

おっしゃる通り、Fedoraは、Redhatから分岐したもので、安定性よりも先進性を優先して新しいものがどんどん突っ込まれてます。それに対してCentOSは、RedHatとの互換性を意識しているため、安定したサーバーシステムを作りたい場合には好まれているようです。
他のディストリビューションは正直あまり知りませんf(^_^;。


> Windows は、どうかとも聞かれました。Windows では、パソコン止まりでつまらない。Linuxなら、Supercomputer まで行きますとお答えしました。埼玉県和光市に理化学研究所は在りますが、公開日でしたら、実物も見られ、説明もしてくれ、質問も出来ます。Supercomputer に Apache は入っていますかと聞いたら、Apache に限らず、Linux soft なら殆ど入っているとの事でした。税金で運営されている以上、その必要性を国民に理解してもらわないといけませんね。
> install 出来ないと、全ての事を疑ってしまいます。fc13には、openJDKが入っています。Adempiereのinternet の記事の多くは、sunJDKを使っています。高田さんにお聞きした所、CentOSとopenJDKでも、動かしているとの事でした。

確かにサーバーとしては、Linuxがいいですよね。
インターネット系の各種サーバ関連ソフトはUnix/Linuxベースですから。
ただ、ビジネスユースとしては、最近、結構Windows Serverを使うケースが増えてきている気もします。
DBは今でもLinuxが好まれてますが、WebやAPの方はWindowsというのを結構見かけます。

ただ、やはり個人的にはWindowsのサーバ機能はブラックボックス化されていて、何かと制約が掛けられていて、自由度が低くてつまらないと感じます。
Apacheの自由度はIISとは比べものにならないですからね。
ADempiereも、コミッターが増えてPRM/SRPMが増えてくれば、インストールも楽になって、そうなったらやはりLinuxの方が上ですね。

> > Java系Webシステムは、Webサーバ、APサーバ、DBサーバの3層アーキになっているので、
> 私も、paradox user だったもので、10年位前に、Borland で 三階層architecture の話 聴きました。
> Enterprise 規模の話だったと思いますが、ademがそれに該当するとは全く思っていませんでした。

Java=Webコンテナ(APサーバ)が必要で、ADempiereはJBOSSを利用しているので、必然的に3層になると理解しています。もしかしたら表現に厳密性を欠いているかもしれません。
JBOSSにはTOMCATという、Webサーバ機能も包含しているWebコンテナが組み込まれていて、ADempiereはログを見る限り、それを使ってWebサーバ、APサーバの機能を実装しているように見えます。
なので、ADempiereのソースが巨大でリソースをくっているのは、JBOSSがラッピングされているからだと思っています。


> Ademの世界って、生産管理にしても、商業高校2年生 工業簿記 2級簿記 製造原価報告書 迄のお話の様に思いましたが。違ってますか。?

おっしゃる通り、機能としてはこの間高橋さんがご説明されていたように、生産管理も実装されているので、その部分を使うとなれば、工業簿記の世界に入ってきますね。
ただ、まずはADempiereを財務会計および、その上流の販売・仕入管理を導入できたうえでの、ネクストステップだと思っているので、現状を考えると、もう少し将来のトピックになってくるのかなと、個人的には感じています。


> > 近いうちにインストールマニュアルに、Linuxの方のことも追記していきたいと思っています。
> もし、私でも、ご協力出来たら、幸いと思っています。

是非是非、お願いします。
さきほど「文書管理」の方に記載しましたが、文書テンプレートのフォーマットを追加しましたので、マニュアルとして整った情報ではなく、メモ書きレベルの断片的な情報でも気軽に書いては、「ADempiereの使い方」としてアップ頂いて、材料がそろった上で、タイミングをみて、マニュアルとして正式公開していくという、進め方もありだと思っています。


> > そこのドライバのセットアップ周りが、Linuxでのインストールの一つの壁で、
> fc12の時、ooobase とposgre をodbc接続しようと、odbcDriver 探して苦労しました。
> fc13 場合も探し始めると、odbcDriver が openOffice 内に用意されている事が判りました。
> fc13では、fc13package内の openOffice, posgre8.4.4, と、このopenOffice内のodbcDriver を使い、繋がりました。
>
> fc13package内の IPAex明朝 IPAexゴシックを install し、fallback directory に link を張りました。綺麗な文字が表示されます。また、system 全体でも、firefox でも、この font 使う様にしました。

なるほど、OpenOffice内のドライバーで、AP-DB間の接続に使われているとは。
ODBCとして、yumでバージョン指定してインストールすれば事足りるのかと思ってましたが、そうでもないんでしょうか。


> > 先日、カンさんも少し話されていましたが、利用状況によってはJavaのヒープメモリを増やすという処置が
> > 必要になってくると思います。Javaはデフォルト512Mしかメモリ領域を確保しないので。
> java -Xmx2048m -Xms2048m -Xmn768m -Xss128k -XX:NewRatio=4 これから、勉強してみます。

でも、エンドユーザの数が少人数で、SOAP等のリアルタイム連携が少なければ、あまり気にしなくてもいいとは思いますよ。

つまり、同時接続のリクエストが多くなると、サーバのハングアップが懸念される、というところです。
Répondre à #58121

Répondre à 58126×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

RE: インストールについて (2012-02-24 10:41 by tomand #62409)

Répondre à 62409×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

RE: Implementation & execute Application (2012-04-25 00:57 by tomand #63404)

安藤です。
adempiere の install には、javaの技術を知らなかったので、
20日もかかり、それから、約1年、
adempiere site の manual など見ましたが、難しかったです。

また FileLoader の Bug がある事が判り、
最新の pache を入れ、migl の SQL を実行し、
そして、CoA の Implementation をしました。
ここ、2週間 compiere site の manual 見ましたが、
私には、解りやすいです。

CompiereDocumentation Home

http://wiki.compiere.org/display/docs/Documentation+Home

ここの、"Pricing" と、"Sales" を読みました。

1Ea Ork Tree Oak Trees may grow quite a bit .
と書かれた $61.75 の Invocce と、
バーコード付きの Delivery Note が、printout されました。

なんとか、動き出した様です。
Répondre à #58126

Répondre à 63404×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

RE: Implementation & execute Application (2012-04-25 23:16 by syatsuzuka #63428)

情報共有、ありがとうございます。

確かにADempiere Wiki(英語のオリジナルの方)は構成があまり美しくなく、ちょっとわかりにくいですが、compiereの方はきれいにまとまっているようですね。
pricingのところをざっと見てみたのですが、確かにADempiere Wikiに比べるとよっぽど親切に説明されてます。

結局、ADempiereのコアとなる機能は、compiereとあまりかわらないと思うので、詳細機能をきちんとおさえている人となると、結局、USのcompiere社の人たちなのかもしれませんね。
Bayuさんは、"ADempiere 3.4 ERP Solutions"をよく書いたなぁと関心してましたが、きっとcompiereの本やマニュアルを読んで、ベースとなるストーリーを書いたんじゃないか、という気がしてきました。
Répondre à #63404

Répondre à 63428×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

RE: インストールについて (2012-01-10 03:27 by ntop007 #61567)

本日、MacOSX10.6.8へインストールしてみました。
  postgresqqlは9.1.2
javadeveloper_for_mac_os_x_10.6__10m3527.dmg
問題なくインストール動作しています。

次回、MySQLでの稼働に挑戦し
できれば、windowsとMacOSX両方でXAMPP上での動作を確認してみたいと思います。

XAMPPが利用可能であれば開発or検証用のインストールが容易になります。
同時に、簡易仮想環境としてXAMPPのインストールでAdempiereのインストールが終了し、
セットアップ前状況での配布もできるようになるかもしれません。
とりあえず、ご報告まで
Répondre à #57983

Répondre à 61567×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

RE: インストールについて (2012-01-11 01:24 by syatsuzuka #61591)

ntopさん、なんかやり手な感じですね。
XAMPPを使う、という発想が私からは出てきませんでしたf(^_^;。

ちょっと教えて頂きたいのですが、ADempiereのインストーラにJBOSSが組み込まれているので、
そうするとXAMPPを入れたとしても、使われるのはMだけになってしまうような気がするのですが(Javaによる実装のため)、
やっぱり嬉しかったりするんですかね。
話しのこしを折ってしまってたらすみません。

個人的にはLAMPPとして、再配布形式でパッケージングできたりしないのかな、なんて思ってます。
といいつつ、手をつけられていませんが、またLinuxを勉強しなおそうか、という気になってきました。
Répondre à #61567

Répondre à 61591×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

RE: インストールについて (2012-11-20 09:29 by tig #66343)

こんにちは、全くの初心者です。

http://thinkit.co.jp/story/2011/01/17/1928
の記事で興味を持ち、インストールを始めました。
記述どうりに進めましたが、サーバーポートエラー5432が出て続きができません。

sqlは9.2
JAVAは7を入れた後、6でないとだめだと気づき6を追加しました。

英語のインストールwikiに、エラー5432の場合、ループバックアダプターをインストールせよとあったので、入れてIPを本体と同じIPに固定しました。
機器はDELL E5510です64BIT windows7です。

どうか御助言よろしくお願いします。
Répondre à #57983

Répondre à 66343×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

RE: インストールについて (2012-11-20 22:29 by syatsuzuka #66359)

どうもはじめまして。

ご参考になるかわかりませんが、以下思いつく点を記載させていただきます。

まず、DBはPostgreSQL9.2を利用していて、そことの接続でエラーが起きている、という理解で正しいでしょうか。

私もバージョンの依存関係についてはあまりきちんと把握できていませんが、Win7にPostgreSQL8.4をインストールしたときは、特にループバックアダプター等の設定をしなくても、問題なくインストールできたので、PostgreSQLのバージョンによる問題かもしれません。
旧バージョン(8.4)の利用、もしくはOracleXEでリトライすることは可能でしょうか?
PostgreSQLのconfファイルは、バージョンによってファイル構成、設定項目が結構変更されているようなので。

それでもなければ、ファイアーウォールによってポートブロックあたりですかね。
Répondre à #66343

Répondre à 66359×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion