Forums: OpenMIDIProject forum (Thread #46039)

Sys./Ex. MIDI THRU switch (2022-06-15 21:32 by «G~Lí†çh» #90269)

when MIDI INPUT from YAMAHA PSR-S*** is opened in Sekaiju:
1) All transmitted Sys./Ex. Chords to PSR-S*** are ignored.
2) DSP insertion part on PSR-S*** stuck to OFF (7F) value: channels 1…16 are can be selected when DSP Insertion part = LEFT, the nearest selectable item to CH1, but when Right1 or Right2 — always jumps to OFF (XG specification doesn't support panel «Right1»/«Right2»/«Left» and Style parts)!
"OutputOn"=off doesn't work as should (all received Sys./Ex. messages still pass through the Sekaiju to the MIDI OUTPUT)!
Have to switch [Sys./Ex. Transmit = OFF] on PSR-S7*** to avoid these issues || switch "InputOn" to OFF in Sekaiju (or "OutputPort" to [None])… Why can't just simply to turn off MIDI THRU for System Exclusive messages (menu item || hotkey || toolbar button || options)?
That's why Sonar and Cubase sets Sys./Ex. MIDI Thru OFF (Filtered) by default…

P.S. still using 32-bit Sekaiju (because don't have a "perfect" laptop for using 64-bit OS)

Répondre à 90269×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion

Re: Sys./Ex. MIDI THRU switch (2022-06-19 12:15 by kuzu #90308)

1)In Sekaiju, SysEx message can be received only in InputCh=n/a' s track.
The other message such as note off, on, channel after, cc#, pc#, key after,
and pitch bend can be received only in InputCh=1 ~ 16's track.

Also, too big size sysEx message may be ignored.
The sysEx message must begin with F0 and end with F7, and the middle must be 00-7F.
MIDI device driver may be corrupted. Please reboot windows.

2)How about turn off MIDI thru,
"Setup" - "MIDI Device and instrument..." - "MIDI Thru" tab.

Répondre à #90269

Répondre à 90308×

You can not use Wiki syntax
Vous n'êtes pas connecté. Pour distinguer vos messages en provenance du reste, vous devez choisir un surnom. (L'unicité du surnom est pas réservé. Il est possible que quelqu'un d'autre pourrait utiliser exactement le même surnom. Si vous voulez l'assurance de votre identité, nous vous recommandons de vous connecter avant de poster.) Connexion